DiskGenius 简介

DiskGenius软件简介

DiskGenius是一款磁盘分区及数据恢复软件。支持对GPT磁盘(使用GUID分区表)的分区操作。除具备基本的建立分区、删除分区、格式化分区等磁盘管理功能外，还提供了强大的已丢失分区恢复功能(快速找回丢失的分区)、误删除文件恢复、分区被格式化及分区被破坏后的文件恢复功能、分区备份与分区还原功能、复制分区、复制硬盘功能、快速分区功能、整数分区功能、检查分区表错误与修复分区表错误功能、检测坏道与修复坏道的功能。提供基于磁盘扇区的文件读写功能。支持VMware、 Virtual PC、 VirtualBox虚拟硬盘文件格式。支持IDE、SCSI、SATA等各种类型的硬盘，及各种U盘、USB移动硬盘、存储卡(闪存卡)。支持FAT12/FAT16/FAT32/NTFS/EXT3文件系统。

DiskGenius软件提供了下列具体功能：

1、支持传统的MBR分区表格式，及GPT磁盘使用的GUID分区表格式，可对GPT磁盘进行分区管理操作。
2、支持IDE、SCSI、SATA等各种类型的硬盘。支持各种U盘、USB移动硬盘、存储卡(闪存卡)。
3、支持FAT12、FAT16、FAT32、NTFS文件系统，可进行文件读写操作，包括复制文件、删除文件等。
4、支持EXT2/EXT3文件系统的文件读取操作。支持Linux LVM2磁盘管理方式。
5、提供在MBR分区表与GUID分区表格式之间的无损转换功能。
6、支持基本的建立分区、删除分区、隐藏分区等操作。可指定详细的分区参数。
7、提供在主分区形式与逻辑分区形式之间的无损转换功能。
8、提供快速格式化FAT12、FAT16、FAT32、NTFS分区的功能。格式化时可指定簇大小、支持NTFS文件系统的压缩属性。
9、可浏览包括隐藏分区在内的任意分区内的任意文件，包括通过正常方法不能访问的文件(如被其它程序以独占方式打开的文件)。可通过直接读写磁盘扇区的方式读写文件、强制删除文件、建立文件夹。
10、提供分配盘符及删除盘符操作。可设置及更改分区卷标、FAT分区的BPB卷标。
11、提供FAT12、FAT16、FAT32、NTFS分区的数据恢复功能。支持已删除文件恢复、分区被破坏、分区被格式化后的文件恢复，用于找回丢失的文件。
12、增强的已丢失分区恢复(重建分区表)功能，可快速找回各种原因丢失的分区。恢复过程中，可即时显示搜索到的分区参数及分区内的文件。搜索完成后，可在不保存分区表的情况下恢复已丢失分区内的已丢失文件。
13、提供分区表的备份与恢复功能。可用于在分区丢失后恢复分区表。
14、可将整个分区备份到一个镜像文件中，可在必要时(如分区被破坏、分区被格式化)还原分区。支持在Windows运行状态下备份系统分区。
15、提供复制分区功能。并提供“复制全部扇区”、“按文件系统结构复制”、“按文件复制”等三种复制方式，以满足不同需求。
16、提供复制硬盘功能。同样提供“复制全部扇区”、“按文件系统结构复制”、“按文件复制”等三种复制方式。
17、支持VMware、 Virtual PC、 VirtualBox虚拟硬盘文件(".vmdk" ".vhd" ".vdi"文件)。打开虚拟硬盘文件后，即可像操作普通硬盘一样操作虚拟硬盘。
18、可在不启动虚拟机的情况下从虚拟硬盘复制文件、恢复虚拟硬盘内的已删除文件(包括分区被格式化及分区被破坏后的文件恢复)、向虚拟硬盘分区复制文件等。
19、支持 ".img" ".ima" 磁盘及分区映像文件的制作及读写操作。
20、支持USB-FDD、USB-ZIP模式启动盘的制作及其文件操作功能。
21、支持磁盘坏道检测与修复功能。
 22、提供对磁盘进行快速分区及快速格式化功能。
23、提供分区表错误检查与更正功能。

版权所有 (C) 1997-2010
http://www.diskgenius.cn


许可协议

DiskGenius软件安装与使用许可协议

请您在使用本软件前仔细阅读如下条款。包括免责条款及对用户的权利限制。您的安装使用行为将视为对本协议的接受，并同意接受本协议各项条款的约束。

《DiskGenius软件安装与使用许可协议》(以下简称“本协议”)是您(个人或单一机构团体)与DiskGenius软件(以下简称“本软件”或“本软件产品”)版权所有人之间的法律协议。在您使用本软件之前，请务必阅读本协议，任何与本协议有关的软件、电子文档等都应是按本协议的条款而授予给您的。同时本协议亦适用于任何有关本软件产品的后期发行和升级。您一旦安装、使用本软件产品，即表示您同意并接受本协议各项条款的约束。如果您拒绝接受本协议的任何条款，请您停止安装或使用本软件。

1、本软件受著作权法及中华人民共和国和国际著作权条约和其它知识产权法及条约的保护，其所有知识产权归本软件作者所有。

2、本软件产品（包括但不限于本软件产品中所含的任何图象、图标、动画、录像、录音、文件和附加程序(dll、exe等)）、随附的帮助文档及本软件产品的任何副本的一切所有权和知识产权，均归本软件作者所有。用户不得单独复制和修改这些材料。

3、本软件产品为共享软件，用户可以非商业性地下载、安装、复制和散发本软件产品，但必须保证本软件的完整性，不能因此而以任何方式任何理由收取费用。如需进行商业性的销售、复制和散发，包括软件预装和捆绑，必须取得本软件作者的书面授权。在没有软件作者书面授权的情况下，用户不能在商业性宣传活动、产品中附加本软件。

4、用户不得对本软件产品进行任何反向工程、反向编译、反汇编等侵权行为。不得修改本软件产品的任何部分。也不得将被修改过的软件收录进光盘、磁盘、网络等媒介中或安装在计算机中。更不得进行非法解密或注册等活动。否则本软件作者将保留依法追纠的权利，侵权者将承担由此产生的法律责任。

5、鉴于用户计算机软、硬件环境的差异性和复杂性，本软件所提供的各项功能并不能保证在任何情况下都能正常执行或达到用户所期望的结果。用户使用本软件所产生的一切后果，软件作者不承担任何责任。

6、本软件作者对使用与安装本软件产品而给用户带来的损害不负责任。这些损害可能来自于与用户安装使用的其他软件的冲突，或由于不能使用本产品而造成的损害，包括（但不限于）直接或间接的个人损害、商业赢利的丧失、贸易中断、商业信息的丢失或任何其它金钱损失。由于使用本软件产品而给用户带来的任何直接或间接损失，软件作者不承担赔偿责任。

7、为方便用户使用本软件产品，及获得技术支持，用户可能需要向软件作者或代理商请求注册(或激活)。注册(或激活)时可能需要提供与注册有关的用户个人信息、电脑硬件信息等数据。我们不会跟踪、监视用户计算机，不会收集用户使用其它软件、文档等信息，不会泄漏用户隐私，不会将这些信息提供给任何第三方。同时，本软件不含有任何旨在破坏用户计算机数据和获取用户隐私信息的恶意代码，不含有任何跟踪、监视用户计算机的功能代码。

8、本软件经过详细的测试，但不能保证与所有的软硬件系统完全兼容。如果出现不兼容的情况，用户可将情况报告给软件作者。如果无法解决兼容性问题，用户可以删除本软件。

9、由于本软件产品可以通过网络等途径下载、传播，对于从非本软件指定站点下载的本软件产品以及从其它介质上获得的本软件产品，软件作者无法保证该软件是否感染计算机病毒、是否隐藏有伪装的木马程序或者黑客软件，不承担由此引起的直接和间接损害责任。

10、本软件提供与磁盘、文件系统、文件操作等有关的功能。由于本软件功能的特殊性，本软件的任何功能都可能给用户的电脑带来损害。用户必须正确地使用本软件。用户愿意使用本软件即表示用户清楚本软件的功能特性及掌握了必要的相关知识，知道本软件的所有操作可能造成的一切后果。由于使用本软件而给用户带来的磁盘损坏、分区丢失、文件丢失、数据丢失，及由此产生的其它后果及任何损失，本软件作者不负责任。

11、本软件会由于用户的需求而不断更新，本软件作者将提供包括用户手册，电子邮件等各种相关信息支持，但不确保支持内容和功能不发生变更。

12、当您不同意或者违背本协议的时候，协议将自动终止，您必须立即删除本软件产品。


DiskGenius 主界面

DiskGenius的主界面由三部分组成。分别是：硬盘分区结构图、分区目录层次图、分区参数图。如下所示：

其中，硬盘分区结构图用不同的颜色显示了当前硬盘的各个分区。用文字显示了分区卷标、盘符、类型、大小。逻辑分区使用了网格表示，以示区分。用绿色框圈示的分区为“当前分区”。用鼠标点击可在不同分区间切换。结构图下方显示了当前硬盘的常用参数。通过点击左侧的两个“箭头”图标可在不同的硬盘间切换。

分区目录层次图显示了分区的层次及分区内文件夹的树状结构。通过点击可切换当前硬盘、当前分区。也可点击文件夹以在右侧显示文件夹内的文件列表。

分区参数图在上方显示了“当前硬盘”各个分区的详细参数(起止位置、名称、容量等)，下方显示了当前所选择的分区的详细信息。

为了方便区分不同类型的分区，本软件将不同类型的分区，用不同的颜色显示。每种类型分区使用的颜色是固定的。如FAT32分区用蓝色显示、NTFS分区用棕色显示等等。“分区目录层次图”及“分区参数图”中的分区名称也用相应类型的颜色区分。各个视图中的分区颜色是一致的。

“当前硬盘”是指当前选择的硬盘。“当前分区”则是指当前选择的分区。本软件对硬盘或分区的多数操作都是针对“当前硬盘”或“当前分区”的操作。所以在操作前首先要选择“当前硬盘”或“当前分区”。

主界面的三个部分之间具有联动关系，当在任意一个图中点击了一个分区(更改当前分区)后，另外两部分将立即切换到被点击的分区。当在“分区目录层次图”中点击了某个文件夹后，右侧的分区参数图将切换成为文件列表，显示当前文件夹下的文件信息。如下图所示：

文件列表显示了文件的图标、名称、大小、类型、以字母表示的属性、短文件名、修改时间、创建时间等信息。该列表会显示所有文件，包括Windows资源管理器在正常情况下无法显示的系统文件、禁止用户访问的文件夹内的文件等。不同属性的文件会以不同的颜色区分。不同容量单位的文件大小也用不同的颜色区分。

主界面的各个部分都支持右键菜单，以方便操作。如下列图所示：


分区操作 - DiskGenius

DiskGenius软件可以执行如下与分区有关的操作：

1、创建新分区
2、激活分区
3、删除分区
4、格式化分区
5、隐藏分区
6、更改分区参数
7、分配、删除盘符
8、备份分区到镜像文件
9、从镜像文件恢复分区
10、复制分区
11、恢复已删除文件或格式化后文件恢复
12、快速分区
13、设置卷标
14、在主分区和逻辑分区之间转换分区类型


建立分区 - DiskGenius

建立分区

创建分区之前首先要确定准备创建的分区类型。有三种分区类型，它们是“主分区”、“扩展分区”和“逻辑分区”。主分区是指直接建立在硬盘上、一般用于安装及启动操作系统的分区。由于分区表的限制，一个硬盘上最多只能建立四个主分区，或三个主分区和一个扩展分区；扩展分区是指专门用于包含逻辑分区的一种特殊主分区。可以在扩展分区内建立若干个逻辑分区；逻辑分区是指建立于扩展分区内部的分区。没有数量限制。

如果要建立主分区或扩展分区，请首先在硬盘分区结构图上选择要建立分区的空闲区域(以灰色显示)。如果要建立逻辑分区，要先选择扩展分区中的空闲区域(以绿色显示)。然后点击工具栏“新建分区”按钮，或依次选择“分区 - 建立新分区”菜单项，也可以在空闲区域上点击鼠标右键，然后在弹出的菜单中选择“建立新分区”菜单项。程序会弹出“建立分区”对话框。如下图所示：

按需要选择分区类型、文件系统类型、输入分区大小后点击“确定”即可建立分区。

对于某些采用了大物理扇区的硬盘，比如4KB物理扇区的西部数据“高级格式化”硬盘，其分区应该对齐到物理扇区个数的整数倍，否则读写效率会下降。此时，应该勾选“对齐到下列扇区数的整数倍”并选择需要对齐的扇区数目。

如果需要设置新分区的更多参数，可点击“详细参数”按钮，以展开对话框进行详细参数设置。如下图：

对于GUID分区表格式，还可以设置新分区的更多属性。设置完参数后点击“确定”即可按指定的参数建立分区。

新分区建立后并不会立即保存到硬盘，仅在内存中建立。执行“保存分区表”命令后才能在“我的电脑”中看到新分区。这样做的目的是为了防止因误操作造成数据破坏。要使用新分区，还需要在保存分区表后对其进行格式化。


激活分区 - DiskGenius

激活分区

活动分区是指用以启动操作系统的一个主分区。一块硬盘上只能有一个活动分区。

要将当前分区设置为活动分区，点击工具栏按钮“激活”，或点击菜单“分区 - 激活当前分区”项，也可以在要激活的分区上点击鼠标右键并在弹出菜单中选择“激活当前分区”项。如果其它分区处于活动状态，将显示下面的警告信息：

点击“是”即可将当前分区设置为活动分区。同时清除原活动分区的激活标志。

通过点击菜单“分区 - 取消分区激活状态”项，可取消当前分区的激活状态，使硬盘上没有活动分区。


删除分区 - DiskGenius

删除分区

先选择要删除的分区，然后点击工具栏按钮“删除分区”，或点击菜单“分区 - 删除当前分区”项，也可以在要删除的分区上点击鼠标右键并在弹出菜单中选择“删除当前分区”项。程序将显示下面的警告信息：

点击“是”即可删除当前选择的分区。


格式化分区 - DiskGenius

格式化分区

分区建立后，必须经过格式化才能使用。本软件目前支持NTFS、FAT32、FAT16、FAT12等文件系统的格式化。

首先选择要格式化的分区为“当前分区”，然后点击工具栏按钮“格式化”，或点击菜单“分区 - 格式化当前分区”项，也可以在要格式化的分区上点击鼠标右键并在弹出菜单中选择“格式化当前分区”项。程序会弹出“格式化分区”对话框。如下图：

在对话框中选择文件系统类型、簇大小，设置卷标后即可点击“格式化”按钮准备格式化操作。
还可以选择在格式化时扫描坏扇区，要注意的是，扫描坏扇区是一项很耗时的工作。多数硬盘尤其是新硬盘不必扫描。如果在扫描过程中发现坏扇区，格式化程序会对坏扇区做标记，建立文件时将不会使用这些扇区。
对于NTFS文件系统，可以勾选“启用压缩”复选框，以启用NTFS的磁盘压缩特性。
如果是主分区，并且选择了FAT32/FAT16/FAT12文件系统，“建立DOS系统”复选框会成为可用状态。如果勾选它，格式化完成后程序会在这个分区中建立DOS系统。可用于启动电脑。
在开始执行格式化操作前，为防止出错，程序会要求确认。如下图：

点击“是”按钮立即开始格式化操作。程序显示格式化进度。如下图：

格式化完成后，如果选择了“建立DOS系统”，程序还会向分区复制DOS系统文件。


隐藏分区 - DiskGenius

隐藏分区(或取消隐藏分区)

一、隐藏分区：

当分区处于隐藏状态时，操作系统将不为其分配盘符，在“我的电脑”中看不到这样的分区。应用程序也不能对其进行访问。但隐藏分区内的文件没有丢失，只是通过正常方式无法访问了。

要隐藏当前选择的分区，请点击菜单“分区 - 隐藏当前分区”项，也可以在要隐藏的分区上点击鼠标右键并在弹出菜单中选择“隐藏当前分区”项。如果当前分区是系统分区或本软件所在分区，程序会显示下列提示：

否则程序将尝试锁定当前分区。如果当前分区正在使用中，程序会询问是否卸载当前分区：

如果锁定或卸载成功，程序将删除当前分区的盘符，最后隐藏分区。分区隐藏后，将在“我的电脑”中消失。但仍在本软件中可见，并可访问分区内的文件。

二、取消隐藏：

要取消分区的隐藏状态，请首先选择要取消隐藏的分区。然后点击“分区 - 取消隐藏状态”菜单项。程序会立即取消这个分区的隐藏状态。


更改分区参数 - DiskGenius

更改分区参数

分区建立后，如果需要对分区的详细参数进行更改，可通过本功能实现。

点击菜单“分区 - 更改分区参数”项，也可以在要更改参数的分区上点击鼠标右键并在弹出菜单中选择“更改分区参数”项。程序显示如下对话框：

通过此功能可调整分区的起止位置及系统标识。

需要注意的是更改系统标识并不等同于分区类型转换，它不能改变文件系统类型。通过本功能对分区大小的调整也不是无损调整，对于已格式化的分区，错误的调整将会造成分区内的文件无法访问！


分配盘符或删除盘符 - DiskGenius

分配盘符或删除盘符

一、分配盘符、或更换盘符：

先选择要分配盘符的分区，然后点击菜单“分区 - 指派新的驱动器号(盘符)”项，也可以在分区上点击鼠标右键并在弹出菜单中选择“指派新的驱动器号(盘符)”项。 程序将弹出“分配盘符”对话框：

选择新盘符后点击“确定”即可为分区分配盘符。同时旧的盘符将被删除。

二、删除盘符：

先选择要删除盘符的分区，然后点击菜单“分区 - 删除驱动器号(盘符)”项，也可以在分区上点击鼠标右键并在弹出菜单中选择“删除驱动器号(盘符)”项。 如果分区正在使用中，程序将显示下列警告信息：

点击“是”即可删除盘符。


备份分区 - DiskGenius

备份分区

备份分区功能是将整个分区中的所有文件数据或其它数据备份到指定的文件(称为“镜像文件”)中。以便在分区数据遭到破坏时恢复。本软件提供了三种备份方式可供选择。
1、备份所有扇区：将源分区(卷)的所有扇区按从头到尾的顺序备份到镜像文件中。而不判断扇区中是否存在有效数据。在对有效数据进行备份的同时，此方式也会备份大量的无用数据，适用于有特殊需要的情况。因为要备份的数据量大，所以速度最慢。并且在将来恢复时只能恢复到源分区、或与源分区大小完全相同的其它分区。
2、按存储结构备份：按源分区(卷)的文件系统结构将有效数据“原样”备份到镜像文件中。备份时本软件将只备份含有有效数据的扇区，没有有效数据的扇区将不备份。此方式速度最快。但与第一种方式一样，将来恢复时也要求目标分区的大小必须与源分区完全相同。
3、按文件备份：将源分区(卷)的所有文件及其它有效数据逐一打包备份到镜像文件中。此方式也不备份无效扇区，所以备份速度较快。恢复时可将备份文件恢复到与源分区不同大小的其它分区(卷)中，只要目标分区(卷)的容量大于源分区的已用数据量总和即可。因此，这种方式比较灵活。恢复时文件的存储位置会被重新安排。一般情况下，新恢复的分区将没有文件碎片。

为了缩减镜像文件的大小，可以选择在备份时对数据进行压缩。但压缩数据会对备份速度造成一点影响。选择的压缩质量越高，备份速度越慢，但镜像文件越小。建议选择“快速压缩”。

要开始备份分区，点击工具栏按钮“备份分区”，或点击菜单“工具 - 备份分区到镜像文件”项。程序将显示下面的对话框：

点击“选择源分区(卷)”按钮选择要备份的分区，程序打开分区选择对话框：

点击要备份的分区，再点击“确定”按钮。接下来选择文件路径、选择备份方式、压缩方式、输入备注(0-800字节)后即可点击“开始”按钮。程序显示下面的警告提示：

点击“确定”按钮。程序将尝试锁定要备份的分区，如果无法锁定，将显示下面的警告提示：

可以在不锁定分区的情况下对分区进行备份，但是在备份程序的运行过程中其它进程正在更改的文件只能备份到备份时一个时点的文件数据。但不影响其它文件的备份。点击“是”按钮即开始备份进程。如下图所示：


从镜像文件还原分区 - DiskGenius

从镜像文件还原分区

当分区数据损坏时，可以从先前备份的镜像文件还原分区，将其还原到备份前的状态。点击菜单“工具 - 从镜像文件还原分区”项，程序弹出“从镜像文件还原分区”对话框：

点击对话框中的“选择文件”按钮，以选择分区镜像文件(.pmf文件)。再点击“选择目标分区(卷)”按钮以选择要还原的分区。对话框中会显示镜像文件的有关信息。如果文件及目标分区选择正确，可以点击“开始”按钮准备还原分区。程序显示下面的警告提示：

确认无误后点击“确定”按钮，程序将开始还原分区进程：

如果原镜像文件是“按文件”备份的，且在备份时源分区没有锁定，还原分区完成后，程序将自动对还原后的数据做必要的检查及更正。


复制分区 - DiskGenius

复制分区

复制分区功能是指将一个分区的数据复制到另一个分区。在备份分区功能中，本软件提供了三种备份数据的方式。类似地，本软件对复制分区的功能也提供了三种复制数据方式。这三种方式分别是：
1、复制所有扇区：将源分区(卷)的所有扇区按从头到尾的顺序复制到目标分区(卷)。而不判断要复制的扇区中是否存在有效数据。此方式可能会复制大量的无用数据，要复制的数据量较大，因此复制分区速度较慢。但这是最完整的复制方式，会将源分区数据“不折不扣”地复制到目标分区。由于此方式不对分区数据进行任何重组，因此要求两个分区大小必须完全相同。
2、按文件系统结构原样复制：按源分区(卷)的数据组织结构将有效数据“原样”复制到目标分区(卷)。复制后目标分区中的数据组织结构与源分区完全相同。复制时会排除掉无效扇区。因为只复制有效扇区，所以此种方式复制分区速度最快。此方式也不对分区数据进行重组，所以同样要求两个分区大小必须完全相同。
3、按文件复制：通过分析源分区(卷)中的文件数据组织结构，将源分区中的所有文件复制到目标分区(卷)。复制时会将目标分区中的文件按文件系统结构的要求重新组织。用此方式复制后，目标分区将没有文件碎片，复制分区速度也比较快。此方式不要求目标分区的容量必须与源分区相同，只要大于源分区的已用数据总量即可。

要复制分区，请点击菜单“工具 - 复制分区”项，也可以从右键菜单中选择“复制分区”菜单项。程序弹出“复制分区”对话框：

该对话框打开后，程序会自动弹出源分区选择及目标分区选择对话框。如下图所示：

选择好源分区与目标分区后，重新回到复制分区对话框。然后根据需要选择一种复制方式。如果两个分区的大小不相同，将只能选择“按文件复制”。之后即可点击“开始”按钮准备复制分区。程序显示下面的警告提示：

确认无误后点击“确定”按钮 。程序尝试锁定分区。如果无法锁定源分区(无法锁定的分区一般包括系统分区及本软件所在的分区)，程序将显示类似下面的提示：

如果要在不锁定源分区的情况下继续复制分区，请点击“是”按钮，程序开始复制进程：

“按文件”复制时，如果源分区没有锁定，复制分区完成后，程序将自动对复制后的目标分区数据做必要的检查及更正。


文件数据恢复 - DiskGenius

文件数据恢复

当计算机内的文件被有意无意的删除、或遭到病毒破坏、分区被格式化后，若想恢复这些已丢失的文件，均可使用本功能。实际上，操作系统在删除文件时，只是将被删除文件打上了“删除标记”，并将文件数据占用的磁盘空间标记为“空闲”。文件数据并没有被清除，还静静地“躺”在磁盘上。只要删除文件后没有建立新的文件，操作系统没有写入新的数据，这些被删除的文件数据就不会被破坏，就有机会通过一定的技术手段将它们“抢救”出来。

格式化操作执行时并不会考虑磁盘上原来的数据内容，也不会先删除旧文件。不同的文件系统类型，格式化的具体操作内容也不同。对于FAT32、FAT16、FAT12等文件系统，格式化时会清除文件分配表(简称FAT，固定位于分区的开始部分，含有文件数据的定位信息)及根目录。文件数据一般不会被清除。对于NTFS文件系统，格式化时新写入的数据没有固定位置要求，但正常情况下每次格式化时的写入位置不会变化。因此旧文件数据大多不会被覆盖，仍存在大量残余信息供我们找到丢失的文件。

本功能就是通过分析残留在磁盘上的文件的部分信息来重新找到文件数据及文件夹的层次结构，从而达到恢复文件数据的目的。

对于整个分区已经丢失的情况，请首先参阅“搜索已丢失分区(重建分区表)”功能，先搜索到丢失的分区。然后可以在保存分区表后、或在不保存分区表的情况下再利用“文件恢复”功能恢复分区内的文件。

分区被破坏的表现有：在“我的电脑”中打开分区时系统提示“未格式化”“需要格式化”，分区属性显示为“RAW”，打开分区后看不到任何文件。遇到这些情况时，都可以通过“误格式化后的文件恢复”功能来恢复文件。

本功能支持NTFS、FAT32、FAT16、FAT12等文件系统类型的硬盘分区、支持使用这些文件系统格式的RAID卷、U盘、存储卡(如数码相机中的SD卡、XD卡等等)。

为保护正在恢复的分区不被再次破坏，本软件在搜索分区内的文件时，会采用只读模式，不会向分区写入任何数据。

要开始恢复文件，首先选择已删除文件所在的分区。然后点击工具栏按钮“恢复文件”，或点击主菜单“工具”中的“已删除或格式化后的文件恢复”菜单项，以打开文件恢复对话框。如下图：

由于格式化后的文件恢复与文件正常删除后的恢复过程不同，我们将这两种情况分别处理。下面是具体的操作方法：

一、误删除文件的恢复：

在恢复文件对话框中，选择“恢复误删除的文件”。如果正在搜索的分区文件系统类型是FAT32，还可以勾选“恢复更早以前删除的文件”复选框。由于FAT32文件系统在删除文件时的特性，有的已删除文件在不进行完整扫描的情况下可能搜索不到。由于“恢复更早以前删除的文件”耗时较长，建议先在不使用该选项的情况下搜索一次，搜索不到时再采用该方式重新搜索。点击“开始”按钮以开始搜索过程：

搜索完成后，恢复文件对话框自动关闭。程序主界面将显示搜索到的文件，每个已删除文件前面都有一个复选框，左侧的文件夹层次图中的条目也加上了复选框。见下图。

对于不能确定归属的文件及文件夹，程序将它们统一放到一个叫做“丢失的文件”的内存文件夹中。如果在原位置找不到要恢复的文件，可以尝试在“丢失的文件”文件夹中查找文件。恢复后查找文件时不要忘了这个文件夹，很可能要恢复的重要文件就在这里。

在恢复文件的状态下，文件列表中的“属性”栏将给已删除文件增加两个标记“D”和“X”。“D”表示这是一个已删除的文件。“X”表示这个文件的数据可能已被部分或全部覆盖，文件数据完全恢复的可能性较小。

为方便用户识别搜索到的文件，可以让程序同时显示未删除的正常文件，方法是点击“查看 - 显示正常文件”菜单项。正常文件没有复选框，不可选择。

要恢复搜索到的文件，请通过复选框选择要恢复的文件。然后在文件列表中点击鼠标右键，或打开“文件”主菜单，选择“复制到”菜单项。接下来选择存放恢复后文件的文件夹，点击确定按钮，程序会将当前选择的文件复制到指定的文件夹中。为防止复制操作对正在恢复的分区造成二次破坏，本软件不允许将文件恢复到原分区。

点击完成按钮，关闭文件复制对话框，程序自动清除已复制的文件的选择状态。以准备选择其它文件。

当所有要恢复的文件都复制出来后。可以通过“分区 - 重新加载当前分区”菜单项释放当前分区在内存中的暂存数据，并从磁盘加载当前分区，显示分区的当前状态。

二、恢复整个分区的文件：

在恢复文件对话框中，选择“恢复整个分区的文件”。然后点击“开始”按钮以开始搜索过程。该恢复方式的搜索时间较长。接下来的操作步骤和“恢复误删除文件”过程相同。参照上面的方法选择与复制文件即可。

关于恢复成功率：已删除文件的恢复技术是通过搜索文件删除后在磁盘上留下的残余信息、经过一定地技术分析而实现的。本软件尝试通过各种先进技术及精准算法复原文件信息，以最大限度地提高文件恢复的成功率。但这种技术可能会受到一些因素的制约，如磁盘碎片的影响、用户创建文件的方式、文件删除后的其它操作造成数据被覆盖等等。无法保证文件恢复能够100％成功。特别是FAT32文件系统，由于文件删除后的残余信息比较少，加之磁盘碎片的影响，一般来讲，恢复的成功率要比NTFS系统低。对于NTFS系统上的文件，只要是直接删除的(未移动到回收站)并且文件数据没有被覆盖，成功率甚至可以接近或达到100％。

关于回收站：根据Windows系统对回收站的功能设计，为防止回收站里的文件出现重名的情况，被移动到回收站的文件(或文件夹，但不包括文件夹中的文件)都会被重新命名(命名格式：'D'+'盘符'+编号+原扩展名)。文件的原名、路径、删除时间等信息则保存到一个名为"INF02"的文件中。清空回收站时，所有这些被重命名的文件都被删除，"INF02"文件被清空，文件的原路径及名称信息丢失。因此，对于回收站被清空的情况，本软件能够搜索到的是这些从回收站删除的、并已被重新命名的文件。由于原路径及名称信息丢失，无法恢复原路径及文件名。要恢复这样的文件，请在名为"RECYCLE"的文件夹下查找，可根据扩展名及文件大小确认文件。由于文件夹内的文件没有被重新命名，所以可以根据文件夹内的文件来确认文件夹是不是要恢复的。


快速分区 - DiskGenius

快速分区

快速分区功能用于快速为磁盘重新分区。适用于为新硬盘分区，或为已存在分区的硬盘完全重新分区。执行时会删除所有现存分区，然后按指定要求对磁盘进行分区，分区后立即快速格式化所有分区。用户可指定各分区大小、类型、卷标等内容。只需几个简单的操作就可以完成分区及格式化。如果不改变默认的分区个数、类型、大小等设置，打开快速分区对话框后(快捷键F6)按下“确定”即可完成对磁盘执行重新分区及格式化操作。

要启动此功能，点击“硬盘 - 快速分区”菜单项，或按“F6”键。软件显示如下对话框：

在默认情况下，本功能会自动选择当前磁盘为快速分区的目标磁盘。如果当前磁盘不是要操作的目标盘，请点击对话框左上角的磁盘名称，程序会弹出磁盘选择窗口。

1、选择分区个数。打开对话框后，直接按下“3、4、5、6”即可快速选择分区个数。也可以通过鼠标点击选择。选择后，对话框右半部分立即显示相应个数的分区列表。默认的分区个数根据磁盘大小确定：60G及以下3个分区，大于60G小于150G时4个分区，大于等于150G小于等于320G时5个分区，大于320G时6个分区。

2、调整分区参数。对话框的右半部分显示了各分区的基本参数，包括分区类型、大小、卷标、是否为主分区等。用户可以根据自己的需要和喜好进行调整。

1)、分区类型：快速分区功能仅提供两种类型供选择：NTFS 和 FAT32。
2)、分区大小：默认的分区大小按如下规则设置：首先按照指定的分区个数计算，如果平均每个分区小于15G，则平均分配分区大小。其次如果平均容量大于(或等于)15G，则第一个分区的大小按磁盘总容量的1/20计算，但不小于25G，如果小于25G则固定为25G。其它分区平均分配剩下的容量。这是考虑到第一个分区一般用于安装系统及软件，太小了可能装不下，太大了又浪费。
在容量输入编辑框前面有一个“锁”状图标。当用户改变了某分区的容量后，这个分区的大小就被“锁定”，改变其它分区的容量时，这个分区的容量不会被程序自动调整。图标显示为“锁定”状态。用户也可以通过点击图标自由变更锁定状态；初始化时或更改分区个数后，第一个分区是锁定的，其它分区均为解锁状态；当使用者改变了某个分区的容量后，其它未被“锁定”的分区将会自动平分“剩余”的容量；如果除了正在被更改的分区以外的其它所有分区都处于锁定状态，则只调整首尾两个分区的大小。最终调整哪一个则由它们最后被更改的顺序决定。如果最后更改的是首分区，就自动调整尾分区，反之调整首分区。被调整的分区自动解锁。
点击“默认大小”的按钮后，软件会按照默认规则重置分区大小。
本功能划分出来的分区，除了使用“剩余容量”的分区以外，其它均为“整数分区”，即在Windows的资源管理器中显示为“整数”大小，看起来更美观。

3)、卷标：软件为每个分区都设置了默认的卷标，用户可以自行选择或更改，也可以通过点击“清空所有卷标”按钮将所有分区的卷标清空。
4)、是否为主分区(GUID分区表没有逻辑分区的概念，此设置对GPT磁盘分区时无效)：可以选择分区是主分区还是逻辑分区。通过勾选进行设置。需要说明的是，一个磁盘最多只能有4个主分区，多于4个分区时，必须设置为逻辑分区。扩展分区也是一个主分区。软件会根据用户的选择自动调整该选项的可用状态。
5)、对齐分区位置：对于某些采用了大物理扇区的硬盘，比如4KB物理扇区的西部数据“高级格式化”硬盘，其分区应该对齐到物理扇区个数的整数倍，否则读写效率会下降。此时，应该勾选“对齐到下列扇区数的整数倍”并选择需要对齐的扇区数目。

3、其它设置：
1)、重建主引导记录(MBR)。这是默认选项，如果磁盘上存在基于MBR的引导管理程序，且仍然需要保留它，请不要勾选此选项。
2)、GPT磁盘的快速分区：本功能同样适用于在GPT磁盘上建立GUID分区表。在快速分区对话框右半部分的顶端，“高级设置”的旁边显示了当前磁盘的分区表类型(MBR或GPT)。
另外对于GPT磁盘，还可以选择对ESP分区及MSR分区的处理方式。在存在ESP分区的情况下，可以“保留现有ESP分区”，可以“创建新ESP分区”。

所有设置调整完毕，即可点击“确定”按钮执行分区及格式化操作。如果磁盘中存在旧的分区，软件会在执行前显示如下提示：

快速分区执行后，磁盘上的原有分区(如果存在)会被自动全部删除。新建立的第一个主分区将会自动激活。


设置卷标 - DiskGenius

设置卷标

DiskGenius软件可以设置及更改分区卷标。

首先选择要设置卷标的分区。然后点击鼠标右键，弹出分区操作菜单，或点击“分区”主菜单。然后选择“设置卷标”菜单项。程序显示如下的对话框：

在“正常卷标”栏输入要设置或更改的卷标名称。点击确定按钮即可完成设置卷标功能。

对于FAT32分区，除了正常卷标外，还可以设置保存在分区引导扇区(DBR)中的卷标。


转换分区类型 - DiskGenius

在主分区和逻辑分区之间转换分区类型

在某些情况下，若要将主分区转换为逻辑分区，或要将逻辑分区转换为主分区，可利用本功能实现。由于MBR分区表格式的限制，最多只能有四个主分区并且最多只能有一个扩展分区。因此在逻辑分区与主分区之间进行转换是有一定限制的。
要将主分区转换为逻辑分区，必须同时满足下列条件：
1、主分区之前存在转换到逻辑分区需要的空闲扇区(一般为一个磁道，比如63个扇区。最少需要一个扇区)。
2、当前磁盘上没有扩展分区，或者要转换的主分区紧邻扩展分区。
要将逻辑分区转换为主分区，则要同时满足下列条件：
1、转换后当前磁盘的主分区数目不多于四个(含当前磁盘只有一个逻辑分区的情况)。
2、要转换的逻辑分区位于扩展分区的两头。
当分区满足上述的转换条件时，相应的菜单项才会有效。否则显示为灰色。

本功能不适用于GPT磁盘(GUID分区表)。

要进行这样的转换，首先选择要转换的分区。然后点击“分区”主菜单，选择“转换为主分区”或“转换为逻辑分区”菜单项。程序立即完成转换。

为了防止误操作，转换后并不会将转换后的分区表立即保存到磁盘。这个更改将在执行“保存分区表”(应用更改)命令之后才会实际写入磁盘并生效。


硬盘操作 - DiskGenius

DiskGenius软件可以执行如下与硬盘有关的操作：

1、搜索已丢失分区(重建分区表)
2、重建主引导记录MBR(重建MBR)
3、复制(克隆)硬盘
4、备份与恢复分区表
5、制作USB启动盘
6、坏道检测与修复
7、快速分区
8、删除所有分区
9、清除保留扇区
10、转换分区表类型
11、分区表错误检查与更正


搜索已丢失分区 - DiskGenius

搜索已丢失分区(重建分区表)

“重建分区表”功能是在原DOS版的基础上重写并增强的功能。它能通过已丢失或已删除分区的引导扇区等数据恢复这些分区，并重新建立分区表。无论是误删除的分区，还是被病毒删除的分区，都可以尝试通过本功能恢复。

分区的位置信息保存在硬盘分区表中。分区软件删除一个分区时，会将分区的位置信息从分区表中删除，不会删除分区内的任何数据。本软件通过搜索硬盘扇区，找到已丢失分区的引导扇区，通过引导扇区及其它扇区中的信息确定分区的类型、大小，从而达到恢复分区的目的。

本功能操作直观、灵活、搜索全面，在不保存分区表的情况下也可以将搜索到的分区内的文件复制出来，甚至可以恢复其内的已删除文件。搜索过程中立即显示搜索到的分区，可即时浏览分区内的文件，以判断搜索到的分区是否正确。

要恢复分区，请先选择要恢复分区的硬盘。选择硬盘的方法有：

1、点击左侧“分区、目录层次图”中的硬盘条目，或硬盘内的任一分区条目。
2、点击界面上部“硬盘分区结构图”左侧的小箭头切换硬盘。

如果仅需要搜索空闲区域，请在“硬盘分区结构图”上点击要搜索的空闲区域。

选择好硬盘后，点击“工具 - 搜索已丢失分区(重建分区表)”菜单项，或在右键菜单中选择“搜索已丢失分区(重建分区表)”。程序弹出“搜索分区”对话框：

可选择的搜索范围有：

1、整个硬盘：忽略现有分区，从头到尾搜索整个硬盘。
2、当前选择的区域：保留现有分区，并且只在当前选择的空闲区域中搜索分区。
3、所有未分区区域：保留现有分区，并且依次搜索所有空闲区域中的已丢失分区。

另外，如果能确信要恢复的分区都是按柱面对齐的，则可以勾选“按柱面搜索(分区按柱面对齐)”选项。这样能提高搜索速度。

设置好搜索选项后，点击“开始搜索”按钮。程序开始搜索过程。

搜索到一个分区后，本软件立即在界面中显示刚刚搜索到的分区，并弹出下面的提示信息：

此时，如果搜索到的文件内有文件，程序会自动切换到文件浏览窗口并显示分区内的文件列表。用户可据此判断程序搜索到的分区是否正确。可以不关闭搜索到分区的提示。即可在主界面中查看刚刚搜索到的分区内的文件。如果通过文件判断该分区不正确，请点击提示对话框中的“忽略”按钮。如果分区正确，请点击“保留”按钮以保留搜索到的分区。点击保留后，程序不会立即保存分区表(不写硬盘)。继续搜索其它分区，直到搜索结束。有时候对话框中还会有一个“这是一个主分区”或“这是一个逻辑分区”的选项。如果DiskGenius显示的主分区或逻辑分区类型不正确，可以通过勾选此选项进行转换。

搜索完成后，程序弹出下面的提示：

搜索完成后，在不保存分区表的情况下，可以立即利用本软件访问分区内的文件，如复制文件等。甚至恢复分区内的已删除文件。但是只有在保存分区表后，搜索到的分区才能被操作系统识别及访问。

如果想放弃所有搜索结果，请点击“硬盘 - 重新加载当前硬盘”菜单项。


重建主引导记录(重建MBR) - DiskGenius

重建主引导记录(重建MBR)

“主引导记录”位于硬盘的第一个扇区中，用于选择并引导操作系统。本软件会在保存分区表时自动检查主引导记录(MBR)，当发现MBR无效时会自动重建MBR。因此对于新硬盘，使用本软件分区后，一般不用专门执行重建主引导记录的功能。

如果MBR遭到破坏，或者需要清除主引导记录中的引导程序，可通过本软件的“重建主引导记录”功能重建MBR。操作方法如下：

点击“硬盘 - 重建主引导记录(重建MBR)”菜单项，程序弹出下列提示：

点击“是”按钮后，程序将用本软件自带的MBR重建主引导记录。


复制硬盘 - DiskGenius

复制硬盘

复制硬盘功能是指将一个硬盘的所有分区及分区内的文件和其它数据复制到另一个硬盘。复制过程中，本软件将按源硬盘中的分区结构，在目标硬盘上建立相同大小、相同类型的分区。然后逐一复制每个分区内的文件及数据。对于复制分区数据的过程，本软件提供了如下三种复制数据的方式：
1、复制所有扇区：将源硬盘的所有扇区按从头到尾的顺序复制到目标硬盘。而不判断要复制的扇区中是否存在有效数据。此方式会复制大量的无用数据，要复制的数据量较大，因此复制速度较慢。但这是最完整的复制方式，会将源硬盘数据“不折不扣”地复制到目标硬盘。
2、按文件系统结构原样复制：按每一个源分区的数据组织结构将数据“原样”复制到目标硬盘的对应分区。复制后目标分区中的数据组织结构与源分区完全相同。复制时会排除掉无效扇区。因为只复制有效扇区，所以用这种方式复制硬盘速度最快。
3、按文件复制：通过分析源硬盘中每一个分区的文件数据组织结构，将源硬盘分区中的所有文件复制到目标硬盘的对应分区。复制时会将目标分区中的文件按文件系统结构的要求重新组织。用此方式复制硬盘后，目标分区将没有文件碎片，复制速度也比较快。
对于使用了本软件不支持的文件系统类型的分区，复制时将采用复制所有扇区的方式，以保证复制后的分区与源硬盘中的分区一致。
本功能要求目标硬盘容量要等于或大于源硬盘。

要复制硬盘，请点击工具栏按钮“复制硬盘”，或点击菜单“工具 - 复制硬盘”项， 也可以从右键菜单中选择“复制硬盘”菜单项。程序弹出“复制硬盘”对话框：

该对话框打开后，程序会自动弹出源硬盘及目标硬盘选择对话框。如下图所示：

选择好源硬盘与目标硬盘后，重新回到复制硬盘对话框。然后根据需要选择一种复制方式。之后即可点击“开始”按钮准备复制硬盘。程序将显示下面的警告提示：

请确认目标硬盘上没有重要数据，或重要数据已做好备份。确认无误后点击“确定”按钮 。程序将尝试锁定两个硬盘中的所有分区。如果无法锁定源硬盘中的分区(无法锁定的分区一般包括系统分区及本软件所在的分区)，程序将显示类似下面的提示信息：

如果要在不锁定源硬盘的情况下继续复制硬盘，请点击“是”按钮，程序将开始复制进程：


备份与还原分区表 - DiskGenius

备份与还原分区表

DiskGenius软件提供了分区表的备份与还原功能。可以将硬盘分区表及各分区的引导扇区等重要数据备份到一个文件中。当硬盘分区表或分区引导扇区遭到破坏时，可以通过分区表备份文件来还原，以达到防止数据丢失的目的。

一、备份分区表：

首先选择要备份分区表的硬盘，然后点击菜单“硬盘->备份分区表”项，或按“F9”键。程序显示文件选择对话框：

输入一个文件名，点击“保存”按钮。程序显示下面的提示，表示备份分区表成功。请妥善保管分区表备份文件。以便在必要时还原。

二、还原分区表：

首先选择要还原分区表的硬盘，然后点击菜单“硬盘->还原分区表”项，或按“F10”键。程序显示文件选择对话框。选择之前备份的分区表备份文件后，程序会在内存中加载文件中保存的分区表，并在主界面中显示出来。以方便用户确认是不是要还原的分区表，以免还原出错。程序弹出如下对话框：

在确认还原分区表之前，请首先通过如上图所示的界面显示检查分区状况。确认无误后，点击对话框中的“是”按钮，程序询问是否同时还原分区引导扇区，请根据情况进行选择。如果选择“否”则只还原分区表，如果选择“取消”则放弃还原，程序不对分区表及引导扇区做任何更改。


制作USB启动盘 - DiskGenius

制作USB启动盘

DiskGenius软件支持USB-FDD模式、USB-ZIP模式、USB-HDD模式启动盘的制作。利用此功能，可以将U盘(或USB硬盘)转换到FDD、ZIP模式，并建立可启动的DOS系统，用于启动电脑。对于支持USB启动的电脑，这样的启动盘可用于系统修复时使用。目前各主板厂商对于USB启动方式没有统一的标准，目前采用的启动模式主要有FDD模式、ZIP模式、HDD模式三种。制作USB启动盘时可根据主板支持的模式进行选择。

一、制作USB-FDD模式的启动盘：

首先选择U盘或移动硬盘，然后点击菜单“工具->制作USB-FDD启动盘”项。程序显示如下的警告提示。请注意在转换前备份重要数据。

点击“是”按钮，显示格式化分区对话框：

在对话框中选择文件系统类型后就可以点击“格式化”按钮。当然也可以先设置簇大小、设置卷标。与格式化分区的操作方法相同。点击“格式化”按钮后程序立即开始转换操作。 然后向磁盘中复制DOS启动文件。转换完成，程序弹出如下提示。请先拔下移动盘，再重新插入。

由于软件版权的原因，本软件使用的DOS系统是与MS-DOS兼容的、小巧、开放的FreeDOS。如果需要使用MS-DOS系统，请用户自行用MS-DOS系统文件替换本软件安装目录下“dos”文件夹内的文件即可。

二、制作USB-ZIP模式的启动盘：

首先选择U盘或移动硬盘，然后点击菜单“工具->制作USB-ZIP启动盘”项，或者通过右键菜单选择“制作USB-ZIP启动盘”项。

接下来的操作过程与制作USB-FDD启动盘时相同。不再详述。

三、制作USB-HDD模式的启动盘：

所谓HDD模式，就是常见的硬盘启动模式。电脑启动时，首先加载硬盘主引导程序，主引导程序寻找活动分区，将控制权交给活动分区中的操作系统。因此正常情况下，一般不需要转换，只要建立分区并格式化、建立DOS系统后就是一个HDD模式的启动盘了。

如果当前磁盘已经工作在FDD或ZIP模式，则可通过此功能转换回HDD模式。具体操作步骤如下：

首先选择U盘或移动硬盘，然后点击菜单“工具->制作USB-HDD启动盘”或“转换到HDD模式”项，或者通过右键菜单选择“制作USB-ZIP启动盘”或“转换到HDD模式”项。程序显示如下的警告提示。请注意在转换前备份重要数据。

点击“是”按钮后，程序立即将磁盘转换到HDD模式，然后询问用户是否立即创建可引导的分区。如下图：

如果点击“否”，转换完成，不建立分区。用户可正常使用这个磁盘。
如果点击“是”，程序显示如下的建立分区对话框：

选择文件系统类型、设置分区大小后，点击“确定”按钮。程序立即建立分区，格式化并复制DOS系统到新分区。HDD模式转换完成。


坏道检测与修复 - DiskGenius

坏道检测与修复

    本软件提供了磁盘坏道检测功能及有限的坏道修复功能。要使用本功能，点击“硬盘 - 坏道检测与修复”菜单项，程序弹出如下对话框：

    请首先选择要检查的硬盘，设定检测范围(柱面范围)。点击“开始检测”按钮，软件即开始检测坏道。发现坏道时会将坏道情况显示在对话框中。如下图所示：

    检测过程中遇到坏道时，检测速度会变慢。检测完毕，软件报告检测到的坏道数目。

    检测完成后，可以通过点击“保存报表”按钮，将检测结果保存到一个文本文件中。以备查用。

    如果要立即尝试修复刚刚检测到的坏道，可点击“尝试修复”按钮。软件显示下面的提示：

    重要说明：坏道修复会破坏坏道附近的数据！在可能的情况下，一定要先对磁盘数据进行备份。如果坏道区域存有重要数据，请不要用本功能修复坏道，而应该将硬盘送到专业的数据恢复中心恢复数据。坏道修复会破坏数据，而不是恢复数据！另外需要说明的是，并不是所有的坏道都能修复，本功能可以修复的坏道种类有限。
    为了数据安全，建议不再使用已出现坏道的磁盘。即使坏道已经修复。尤其不要在其上存放重要数据。
    如果没有进行过坏道检测，或者运行本软件之前用其它软件进行过坏道检测，为节省时间，也可以在不检测的情况下直接用本软件修复坏道。

    如果修复成功，软件会在检测结果中报告“已修复”：

    修复完成，软件报告已修复的坏道个数。请实际检测修复结果。


删除所有分区 - DiskGenius

删除所有分区

利用本功能，DiskGenius软件可以对当前硬盘执行一次性删除所有分区的操作。

首先选择要删除分区的磁盘。然后点击“硬盘”主菜单，选择“删除所有分区”菜单项。程序显示如下提示：

在确认当前磁盘没有重要文件，或重要文件已备份后，可以点击“是”按钮以完成删除所有分区的操作。


清除保留扇区 - DiskGenius

清除保留扇区

    本软件所说的保留扇区，是指从硬盘第二个扇区(MBR扇区后面的扇区)开始，到其第一个分区起始扇区之前的，不超过一个磁道的扇区。多数情况下，一个磁道为63个扇区，而第一个分区一般从第63(从0开始编号)个扇区开始，除去MBR扇区，要清除的扇区为62个。

    对于每道扇区数不是63，及第一个分区不是从63扇区开始的情况，本软件会对要清除的扇区数目做判断，以保证不清除保留扇区以外的其它扇区。

    要执行本功能，请先选择要清除保留扇区的硬盘，然后点击“硬盘 - 清除保留扇区”菜单项，程序弹出下列提示：

    点击“确定”按钮以执行清除保留扇区的功能。
    本功能不适用于使用GUID分区表的GPT磁盘。


转换分区表类型 - DiskGenius

转换分区表类型

    本软件支持传统的MBR分区表类型及较新的GUID分区表类型。必要时可通过本软件在这两种分区表类型之间进行无损转换。

    转换时不会破坏文件数据，但是对于不支持GUID分区表格式的操作系统，将无法访问使用GUID分区表的磁盘分区及其文件！

    一、转换分区表类型为GUID格式

    本功能用于将磁盘分区表类型转换为GUID。转换前磁盘的首尾部必须要有转换到GUID分区所必须的空闲扇区(几十个扇区即可)。否则无法转换。要执行该操作，选择要转换的磁盘后，点击菜单“硬盘 - 转换分区表类型为GUID格式”项，程序弹出如下提示：

    请确认转换后使用该磁盘的操作系统支持GUID分区表格式，否则转换后该磁盘分区将无法访问！点击“确定”按钮完成转换。执行“保存分区表”命令后该转换才会实际生效。

    二、转换分区表类型为MBR格式

    本功能用于将分区表类型转换回传统的MBR格式。由于MBR分区表有一定的限制(如主分区数目不能超过四个等)，这种转换有一定的条件限制。因此在转换时，如果分区数目多于四个，本软件将首先尝试将后部的分区逐一转换为逻辑分区。如果无法转换到逻辑分区(一般是由于分区前没有转换到逻辑分区的空闲扇区)，分区表类型转换将失败。

    要执行该操作，选择要转换的磁盘后，点击菜单“硬盘 - 转换分区表类型为MBR格式”项，程序弹出如下提示：

    如果磁盘容量超过2TB，转换为MBR格式后，超过2TB的部分容量将无法使用。另外如果GPT磁盘上安装有基于EFI架构的操作系统，转换到MBR类型后该操作系统将无法启动。确认无误后点击“确定”按钮开始转换。


分区表错误检查与更正 - DiskGenius

分区表错误检查与更正

    利用本软件，可对硬盘分区表错误进行检查与更正。对于硬盘存在较严重问题的情况，运行本软件后，软件会立即显示错误情况报告。

    要手动执行本功能，请先选择要检查分区表错误的硬盘，然后点击“工具 - 检查分区表错误”菜单项，程序即开始检查当前硬盘的分区表错误情况。如果没有检测到错误，软件将报告“没有发现错误”。

    如果检测到了分区表问题，将显示下列形式的分区表错误报告对话框：

    如果检测到的分区表错误为本软件能自动更正的错误。则对话框中的“更正”按钮将为有效状态，可以点击这个按钮以更正错误。否则需要用户按照软件提示自行更正错误。


虚拟硬盘及映像文件 - DiskGenius

DiskGenius软件可以执行如下与虚拟硬盘及磁盘分区映像文件有关的操作：

1、创建VMWare虚拟硬盘文件。
2、创建Virtual PC虚拟硬盘文件。
3、创建VirtualBox虚拟硬盘文件。
4、创建 ".img" 磁盘或分区映像文件。
5、操作虚拟硬盘或磁盘映像及其分区。


创建VMWare虚拟硬盘文件 - DiskGenius

创建VMWare虚拟硬盘文件

本软件支持VMWare虚拟硬盘文件的创建，虚拟硬盘内分区及其文件的操作。建立虚拟硬盘文件的步骤如下：

点击“硬盘 - 新建VMWare虚拟硬盘文件”菜单项。程序弹出如下对话框：

设置文件路径及名称，设置容量，选择版本、适配器类型。还可以选择是否立即分配硬盘空间及是否按2G大小分割文件。这些选项与VMWare软件创建硬盘时的选项一致。

设置好选项后，点击“创建”按钮即可建立虚拟硬盘文件。硬盘创建成功后，本软件会立即打开新创建的文件。也可以在需要时通过点击“硬盘 - 打开虚拟硬盘文件”菜单项。操作方法参见“操作虚拟硬盘及其分区”。


创建Virtual PC虚拟硬盘文件 - DiskGenius

创建Virtual PC虚拟硬盘文件

本软件支持Virtual PC虚拟硬盘文件(".vhd"文件)的创建，虚拟硬盘内分区及其文件的操作。建立虚拟硬盘文件的步骤如下：

点击“硬盘 - 新建虚拟硬盘文件 - 新建Virtual PC虚拟硬盘文件”菜单项。程序弹出如下对话框：

Create New VirtualPC Disk File

设置文件路径及名称，设置容量。还可以选择是否立即分配硬盘空间。

设置好选项后，点击“确定”按钮即可建立虚拟硬盘文件。硬盘创建成功后，本软件会立即打开新创建的文件。也可以在需要时通过点击“硬盘 - 打开虚拟硬盘文件”菜单项。操作方法参见“操作虚拟硬盘及其分区”。


创建VirtualBox虚拟硬盘文件 - DiskGenius

创建VirtualBox虚拟硬盘文件

本软件支持VirtualBox虚拟硬盘文件(".vdi"文件)的创建，虚拟硬盘内分区及其文件的操作。建立虚拟硬盘文件的步骤如下：

点击“硬盘 - 新建虚拟硬盘文件 - 新建VirtualBox虚拟硬盘文件”菜单项。程序弹出如下对话框：

Create New VirtualBox Disk File

设置文件路径及名称，设置容量。还可以选择是否立即分配硬盘空间。

设置好选项后，点击“确定”按钮即可建立虚拟硬盘文件。硬盘创建成功后，本软件会立即打开新创建的文件。也可以在需要时通过点击“硬盘 - 打开虚拟硬盘文件”菜单项。操作方法参见“操作虚拟硬盘及其分区”。


创建".img"磁盘映像 - DiskGenius

创建".img"磁盘映像文件

本软件支持不压缩的磁盘及分区映像文件。无论映像文件的扩展名是什么，如".img"、".ima"、".vfd"、".flp"，只要不是压缩的格式，都可以通过本软件打开，可以对映像内的文件进行操作。建立".img"磁盘 映像文件的步骤如下：

点击“硬盘 - 新建".img"映像文件”菜单项。程序弹出如下对话框：

设置文件路径及名称。然后选择容量 。本软件内置了360K、720K、1.2M、1.44M、2.88M五种标准软盘映像可供选择，也可以自定容量。当选择了自定容量时，还可以进一步设置映像的类型 - 硬盘映像或分区映像。硬盘映像就像一块硬盘，可以再分区。分区映像与软盘映像相似，不能再分区，只能格式化。设置完成后，就可以点击“确定”按钮制作映像文件了。

默认情况下，映像制作完成时，本软件会在映像中建立可引导的DOS系统。这样，这个可引导的映像文件就可以直接用于引导虚拟机系统，或者用于制作可启动光盘了。由于涉及到软件版权问题，本软件内置的DOS系统没有采用MS-DOS，而是采用了与MS-DOS兼容、小巧、开放的FreeDOS。如果用户需要改用MS-DOS，可以自行将本软件安装目录下"dos"文件夹内的文件替换成MS-DOS的文件。

映像制作完成后，映像文件会被本软件自动打开，如下图所示。此时，可以利用本软件提供的文件复制功能向映像中添加其它文件。


操作虚拟硬盘及其分区 - DiskGenius

操作虚拟硬盘及其分区

本软件支持对VMWare虚拟硬盘文件、".img"等格式磁盘映像文件的操作，包括对虚拟硬盘 或磁盘映像内的分区进行操作、文件操作等。

首先打开虚拟硬盘(或磁盘映像)文件，点击“硬盘 - 打开虚拟硬盘文件”菜单项。选择要打开的虚拟硬盘(或磁盘映像)文件后，程序会加载这个文件。需要说明的是，虚拟硬盘只在本软件中打开，可以通过本软件对其进行操作。并没有将其加载到操作系统中 ，在“我的电脑”中是看不到它的，也不能为虚拟硬盘内的分区分配盘符。

虚拟硬盘打开后，就可以像操作普通硬盘一样操作虚拟硬盘了。除不能分配盘符外，其它功能都适用，包括分区的建立、删除、格式化、文件复制、文件恢复、分区恢复、分区复制、硬盘复制等等。

虚拟硬盘打开后，界面显示如下。具体的分区及文件操作与普通硬盘相同，不再详述。


文件操作 - DiskGenius

DiskGenius软件可以执行如下与文件有关的操作：

1、显示分区(卷)内的文件列表
2、从分区复制文件
3、复制文件到当前分区
4、强制删除文件
5、建立文件夹

已删除文件恢复请参阅“文件恢复”。


文件列表 - DiskGenius

显示分区(卷)内的文件列表

通过DiskGenius软件，可以查看分区内的任何文件，不受操作系统的限制。正常情况下，为保护重要文件的安全及维护系统的稳定运行，操作系统隐藏了很多文件，不让用户看到。本软件在显示文件列表时，采用了直接分析文件系统格式、直接读写磁盘扇区的方式，因此完全不受操作系统的限制。可以查看到分区内的所有文件。

本软件采用了类似“Windows资源管理器”的文件列表显示方式，左侧窗口显示文件夹的层次结构，右侧窗口显示文件的详细信息列表。默认情况下，右侧窗口显示的是分区参数。当用户点击了左侧窗口中的任一文件夹时，右侧窗口会自动切换到显示文件列表。也可以通过点击右侧窗口上方的“浏览文件”标签来切换。如下图：

本软件显示的文件属性有：类型图标、文件名、大小、文件类型、用字母表示的属性、短文件名、修改时间、创建时间。具有“隐藏”、“系统”、“压缩”、“加密”等属性的文件，分别用不同的颜色显示，以示区别。其中“用字母表示的属性”各字母代表的属性含义如下：

“D”、“X”表示的属性只在恢复已删除文件时使用。

通过鼠标点击可以选择文件。点击时可以配合使用“Shift”、“Ctrl”键以实现多选。


复制文件

从分区复制文件

DiskGenius软件可以将分区内的任何文件复制到指定的文件夹中。不受操作系统权限限制。

首先在文件列表中选择要复制的文件，可以多选。然后在被选文件上点击鼠标右键，弹出文件操作菜单，如下图所示。也可以通过主菜单“文件”中的菜单项实现相同功能。

选择“复制到”菜单项，然后选择一个文件夹。程序会将选择的文件复制到指定的文件夹中。


复制文件到当前分区 - DiskGenius

复制文件到当前分区

DiskGenius软件可以向NTFS/FAT32/FAT16/FAT12分区内复制文件，无论这个分区是否隐藏、是否有盘符。 完全不受操作系统的权限限制。但是，由于这样的操作是“强制性”的，可能不符合操作系统或使用这个分区的软件的要求，因此具有一定的危险性。请用户谨慎操作。

为方便操作，本软件提供了几种向分区复制文件的方法。在复制之前，请首先找到并选择目标分区中的目标文件夹。

1、通过菜单操作。

选择好目标分区及目标文件夹后，在“浏览文件”窗口点击鼠标右键，在弹出菜单中选择“复制文件到当前分区”项。也可以通过主菜单选择“文件->复制文件到当前分区”项。如下图：

程序显示“选择文件对话框”，选择(可多选)要复制的文件后，程序即开始将选择的文件复制到目录分区的指定目录中。此方法不可以复制文件夹，只能复制文件。要复制文件夹及其所有文件，请采用下面的方法。

2、通过鼠标拖动操作。

选择好目标分区及目标文件夹后，在“资源管理器”等文件管理程序中选择要复制的文件(夹)。然后用鼠标左健拖动要复制的文件(夹)到本软件的“分区及文件树”或“浏览文件”窗口中的指定文件夹，释放鼠标。程序显示如下提示：

点击“是”按钮后程序将开始复制文件。

3、通过快捷键操作。

首先在“资源管理器”等文件管理程序中选择要复制的文件(夹)，然后按“Ctrl_C”键。回到本软件，找到并选择目标分区及目标文件夹后按“Ctrl_V”键，程序显示如文件拖动方法中相同的提示对话框。点击“是”按钮后即开始复制文件。


删除文件 - DiskGenius

强制删除文件

DiskGenius软件提供了“强制删除文件”的功能。它能绕过文件系统驱动，通过直接写磁盘的方式达到删除文件的目的。它可以删除系统分区以外的其它分区上的文件。删除文件功能可用于删除正常情况无法删除的文件或文件夹。

首先在文件列表中选择要删除的文件，可以多选。然后在被选文件上点击鼠标右键，弹出文件操作菜单，如下图所示。也可以通过主菜单“文件”中的菜单项实现相同功能。

选择“强制删除”菜单项，程序将首先锁定文件所在的分区。为防止数据丢失，请在删除文件前首先退出使用该分区的所有程序，关闭该分区的所有文件。删除文件完毕后，该分区即可正常使用。


建立文件夹 - DiskGenius

建立文件夹

用DiskGenius软件可以在其所支持类型的分区中建立文件夹。它是通过直接写磁盘的方式实现建立文件夹的。

首先在文件列表中选择要建立文件夹的路径，然后点击鼠标右键，弹出文件操作菜单，如下图所示。也可以通过主菜单“文件”中的菜单项实现相同功能。

选择“新建文件夹”菜单项，显示建立文件夹对话框。然后输入新文件夹的名称。点击“确定”即开始建立文件夹。如下图：

在建立文件夹之前，程序将首先锁定文件所在的分区。为防止数据丢失，请在建立文件夹前首先退出使用该分区的所有程序，关闭该分区的所有文件。建立文件夹完毕后，该分区即可正常使用。


启动DOS版 - DiskGenius

重新启动系统并运行DOS版DiskGenius软件

    某些功能在Windows系统下可能无法完成，需要在DOS系统下操作。本软件提供了一种在Windows下直接启动到DOS系统并运行DOS版DiskGenius软件的功能。不需要另外的启动光盘、启动U盘，也不需要在硬盘上安装DOS系统。启动并运行DOS版DiskGenius软件后，通过DOS版DiskGenius软件看到的硬盘分区与在Windows下看到的完全相同。再次重新启动电脑时，仍将启动到现有的Windows系统。

    要执行本功能，请点击“文件 - 重新启动系统并运行DOS版DiskGenius软件”菜单项。程序弹出如下提示：

    请在点击“确定”按钮之前首先保存各软件中未保存的数据并关闭所有正在运行的应用程序。点击“确定”按钮之后系统将重新启动。重新启动后，系统自动启动到DOS系统并运行DOS版DiskGenius软件。

    在DOS版DiskGenius中完成操作后可以关机或重新启动。下一次启动电脑后，电脑将自动恢复启动到Windows系统的状态。